Discuss general Sibelius issues here. Get help with Sibelius and Sibelius Support.
Posts: 2
Joined: Fri May 22, 2020 8:06 pm
Sibelius Version: 7.5
Operating System: Mac


Post by Dodsterp » Fri May 22, 2020 8:10 pm

I just tried to log into my Sibelius 7.5. I've been using for a couple years now.
Suddenly I get this message:
eLicenser Control Error
Application GA Classics CRUNCH AU has cause the following error:
eicensoer contain no valid license for this application

I tried clicking Cancel And retry several times and got stuck it wouldnt move.
What the hell?
I have my original SCEP codes and upgrade codes.
Why did this happen and what do I do?
Dorothy Pettit


by Sponsor

Forum Sponsor

Posts: 735
Joined: Fri Jun 24, 2016 7:20 pm
Sibelius Version: Ult. 2019.9/7.51/6.2
Operating System: Windows


Post by MikeLyons » Sat May 23, 2020 7:31 am

This error is nothing to do with your sib license, but with, apparently, a VSTi that you are using. If you have an eLicenser (such as a Steinberg dongle) then you need to synchronise it periodically. You will have an elicenser entry on your Start menu (Windows) or equivalent on a MAC.

This forum is not patrolled very regularly any more. For sibelius issues you would get much quicker responses from either the official Avid Sibelius forum ( ... &groupid=3) or from the FB page (
Sib 6.2, 7.5 and 2020.3, Windows 10, 32GB RAM, 8TB 7200RPM Storage, 2TB SSD, Note Performer 3.1, EWQLSO, EWQLSC, Harmony Assistant and some others.

Post Reply