Latency settings, and configuration options

Discussion of playback and midi issues go here.
Jonpgtr
Posts: 3
Joined: Wed Mar 31, 2021 4:14 pm
Sibelius Version: Ultimate
Operating System: Windows

Latency settings, and configuration options

Post by Jonpgtr » Fri Apr 02, 2021 3:22 pm

I just cross-graded from Sibelius to Ultimate, and also installed Noteperformer. I'm on Windows 10.

I have two questions:

1. I'm getting a small amount of latency when inputting notes (from a midi keyboard, or the PC keyboard). I've found I can reduce this in various ways, I'm just wondering what impact (if any), these adjustments may have elsewhere.
For example, with the default Audio Engine set-up - Interface: Primary Sound Driver (DS), buffer size 4096, sample rate 44100 - I'm getting 96.88 ms latency. I can reduce this by raising rhe sample rate.
Alternatively, I can set the Interface to UMC ASIO Driver (I have a Behringer UMC204), and adjust either the Buffer size downward or the sample rate upward. This produces the least latency at the extreme settings.
I'm guessing this must have some impact elsewhere, so is there some optimum balance, or does it depend on the music I'm creating (instruments, tracks, and so on)?

2. In Configuration I have a list of options, but they don't all work. I get sounds from Noteperformer and from Sibelius 7 First Sounds (and General Midi basic). The rest - four iterations of Sibelius 7 Sounds, inc. Chamber, Jazz, Lite, are all silent. Is there something else I need to download and/or install?

Also, when using Noteperformer, there is a significant delay (not connected to latency settings) of around a second when both starting playback and stopping. Is this normal, or can it be fixed?

Re: Latency settings, and configuration options

by Sponsor

Forum Sponsor
 

MikeLyons
Posts: 964
Joined: Fri Jun 24, 2016 7:20 pm
Sibelius Version: Ult. 2020.6/7.51/6.2
Operating System: Windows

Re: Latency settings, and configuration options

Post by MikeLyons » Fri Apr 02, 2021 7:58 pm

Jonpgtr wrote:
Fri Apr 02, 2021 3:22 pm
I just cross-graded from Sibelius to Ultimate, and also installed Noteperformer. I'm on Windows 10.

I have two questions:

1. I'm getting a small amount of latency when inputting notes (from a midi keyboard, or the PC keyboard). I've found I can reduce this in various ways, I'm just wondering what impact (if any), these adjustments may have elsewhere.
For example, with the default Audio Engine set-up - Interface: Primary Sound Driver (DS), buffer size 4096, sample rate 44100 - I'm getting 96.88 ms latency. I can reduce this by raising rhe sample rate.
There will always be some latency in the system. It's only really important when either using sounds from two different sources. NP also adds about 1 second of latency of its own which helps it to achieve much more natural sounding playback. Do not change the sample rate to anything other than 44100. Sib still doesn't play well with 48K.
Jonpgtr wrote:
Fri Apr 02, 2021 3:22 pm
Alternatively, I can set the Interface to UMC ASIO Driver (I have a Behringer UMC204), and adjust either the Buffer size downward or the sample rate upward. This produces the least latency at the extreme settings.
I'm guessing this must have some impact elsewhere, so is there some optimum balance, or does it depend on the music I'm creating (instruments, tracks, and so on)?
You should ALWAYS use an ASIO or WASAPI driver wherever possible. You need to strike a balance in your settings that gets latency as low as possible while maintaining quality of sound output. Trial and error.
Jonpgtr wrote:
Fri Apr 02, 2021 3:22 pm
2. In Configuration I have a list of options, but they don't all work. I get sounds from Noteperformer and from Sibelius 7 First Sounds (and General Midi basic). The rest - four iterations of Sibelius 7 Sounds, inc. Chamber, Jazz, Lite, are all silent. Is there something else I need to download and/or install?

Also, when using Noteperformer, there is a significant delay (not connected to latency settings) of around a second when both starting playback and stopping. Is this normal, or can it be fixed?
If the Jazz/chamber etc configs are not working then they must not be seeing the same output as the NP or Plain Sibelius. It is the combination of Audio Enging options and Windows sound path that allows you to hear sound output. There is also the possibility that you have not fully downloaded the sibelius library - some 32GB (Yes, 32GB). It will take a long while to download. The attached shows the size of my Sib sounds folder. Yours should be within a gnat's crotchet of this value and you should have the same number of files and folders.
sib sounds folder size.png
sib sounds folder size.png (20.43 KiB) Viewed 189 times
Sib 6.2, 7.5 and 2021.2, Windows 10, 32GB RAM, 8TB 7200RPM Storage, 2TB SSD, Note Performer 3.3.2, EWQLSO, EWQLSC, Harmony Assistant and some others. mike@mike-lyons.co.uk

Jonpgtr
Posts: 3
Joined: Wed Mar 31, 2021 4:14 pm
Sibelius Version: Ultimate
Operating System: Windows

Re: Latency settings, and configuration options

Post by Jonpgtr » Fri Apr 02, 2021 10:59 pm

Thanks - that makes sense about the latency.

The sound files issue did actually occur to me after I posted, and I did some more digging. I had downloaded a Sibelius Sounds Updater, and hadn't realised there was a whole other set of sound files for Ultimate! I've now downloaded them (5 hours at my broadband speed!), and they are installing as I write...

Thanks again!

MikeLyons
Posts: 964
Joined: Fri Jun 24, 2016 7:20 pm
Sibelius Version: Ult. 2020.6/7.51/6.2
Operating System: Windows

Re: Latency settings, and configuration options

Post by MikeLyons » Sat Apr 03, 2021 10:04 am

Yeah. My advice, make yourself a meal, have a brew and watch a bit of telly. I have a superfast broadband and it was about 3 hours on that. Make sure your machine doesn't sleep or hibernate while the download process is going on or you will end up with a corrupted file.
Sib 6.2, 7.5 and 2021.2, Windows 10, 32GB RAM, 8TB 7200RPM Storage, 2TB SSD, Note Performer 3.3.2, EWQLSO, EWQLSC, Harmony Assistant and some others. mike@mike-lyons.co.uk

Jonpgtr
Posts: 3
Joined: Wed Mar 31, 2021 4:14 pm
Sibelius Version: Ultimate
Operating System: Windows

Re: Latency settings, and configuration options

Post by Jonpgtr » Sat Apr 03, 2021 10:21 am

Yes, thanks. Again I did check for that - I let it go overnight, with my sleep setting set to "never". (I mean the PC power setting, not my own. I slept like a baby. :lol: )

MikeLyons
Posts: 964
Joined: Fri Jun 24, 2016 7:20 pm
Sibelius Version: Ult. 2020.6/7.51/6.2
Operating System: Windows

Re: Latency settings, and configuration options

Post by MikeLyons » Sat Apr 03, 2021 2:12 pm

Jonpgtr wrote:
Sat Apr 03, 2021 10:21 am
I let it go overnight, with my sleep setting set to "never". (I mean the PC power setting, not my own. I slept like a baby. :lol: )
I'm jealous. Not sleeping well at the moment. Glad it's sorted.
Sib 6.2, 7.5 and 2021.2, Windows 10, 32GB RAM, 8TB 7200RPM Storage, 2TB SSD, Note Performer 3.3.2, EWQLSO, EWQLSC, Harmony Assistant and some others. mike@mike-lyons.co.uk

Post Reply