Avid Link not working, can't login

Sibelius beginners can discuss all things Sibelius here ("how do I...?").
jaybee
Posts: 2
Joined: Tue Apr 30, 2019 6:52 am
Sibelius Version: 2019
Operating System: Windows

Avid Link not working, can't login

Post by jaybee » Tue Apr 30, 2019 8:08 am

Attempting to run Sibelius (monthly subscription) on my Windows 10 laptop, completed the downloads etc, but am unable to login to Avid Link.

After clicking the Sibelius icon I see a menu with options (Sibelius Ultimate trial, activate, Sibelius first etc) and then Avid Link eventually opens up.

But after entering account details it hangs, displaying "signing in", and then after a couple of minutes it times out, ending with the message "unknown error" and a red cross. My account details work perfectly on the website.

That means so far - it has been a very long 48 hours already - I have not managed to activate my subscription and can only run the 30-day Ultimate trial (which now has only 28 days left).

Any ideas? I have already uninstalled and reinstalled, tried turning firewall off as per a suggestion I saw elsewhere, but no joy.

Re: Avid Link not working, can't login

by Sponsor

Forum Sponsor
 

andyg
Posts: 1393
Joined: Tue Feb 14, 2006 8:55 pm

Re: Avid Link not working, can't login

Post by andyg » Tue Apr 30, 2019 6:34 pm

This is an unofficial forum and nobody from Avid is here. You should ask this question at the official Sibelius Forum: https://www.sibelius.com/cgi-bin/helpce ... ?groupid=3

Avid monitor that site, as it's theirs! If no forum members can answer your question (and they probably will) then one of Avid's staff, usually Ingrid Guce, will help you out.

jaybee
Posts: 2
Joined: Tue Apr 30, 2019 6:52 am
Sibelius Version: 2019
Operating System: Windows

Re: Avid Link not working, can't login

Post by jaybee » Wed May 01, 2019 8:28 am

andyg wrote:This is an unofficial forum and nobody from Avid is here. You should ask this question at the official Sibelius Forum:

Avid monitor that site, as it's theirs! If no forum members can answer your question (and they probably will) then one of Avid's staff, usually Ingrid Guce, will help you out.
Indeed. I had already tried there and was waiting for a reply.
Aleksandra from Avid has now sorted the problem for me - basically involved uninstalling, manually deleting a number of residual files, and reloading Avid Link by itself first.

andyg
Posts: 1393
Joined: Tue Feb 14, 2006 8:55 pm

Re: Avid Link not working, can't login

Post by andyg » Wed May 01, 2019 8:58 am

Glad to hear that it's sorted! :)

This is a quiet place these days, there are three or four of us around to help if we can, but you'll get much faster responses on the official forum.

rolfschnegg
Posts: 1
Joined: Sun May 05, 2019 12:39 pm
Sibelius Version: 2019.4.1
Operating System: Mac

Re: Avid Link not working, can't login

Post by rolfschnegg » Sun May 05, 2019 12:46 pm

Aleksandra from Avid has now sorted the problem for me - basically involved uninstalling, manually deleting a number of residual files, and reloading Avid Link by itself first.
Can you please pass me the solution from Alexandra? I have exactly the same problem, the official support unfortunately does not answer anymore. Although I did get a possible solution, it did not work. I have not heard from Avid since.

Thanks!

Post Reply